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Installation and Usage 
 
 
Add any number of pick-lists, pick-list items, and/or fields to the ACT! By Sage 
Contact, Group or Company records, using an Excel spreadsheet holding the 
field definitions. 
 
Instead of wending your way through the interactive Field Definition wizard, 
create a spreadsheet holding the non-default values for the fields you want to 
define, then “batch” the process.  Quick, easy, effortless!  And Batch Field 
Creator can also create pick-lists (“Dropdown Lists”) and add pick-list items the 
same way. 
 
(Requires Microsoft Excel v9.0 or higher to edit the field definition spreadsheet.) 
 
 

Installation 
 

1. Shut down all running programs 
2. RunInstall_BatchFieldCreator.exe 
3. Follow the instructions on the screen.  Restart your computer if 

prompted to do so. 
 
This will create the \TNHG\BatchFieldCreator folder within your Windows 
“program files” folder (usually c:\program files), and install 
BatchFieldCreator.exe (and all necessary supporting files) into that folder.  It 
will also add the TNHG group to your Start > Programs menu, and add the Batch 
Field Creator sub-folder. 
 
 
 
 

Usage 
 
 
To use Batch Field Creator, you first create your ACT! By Sage database (see 
ACT! documentation for additional information of creating a new database.)  
Then, you develop a spreadsheet detailing the fields, pick-lists and/or pick-list 
items to be added to the database.  If you will be adding fields to more than one 
entity (Contact, Group or Company), you should develop an individual 
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spreadsheet for each entity where new fields will be added using Batch Field 
Creator. 
 
 
 

Pick-list, Item and Field Definition Spreadsheet 
 
One of the supporting files installed into the \TNHG\BatchFieldCreator folder is 
the BFC_Skeleton.xls file.  Open this spreadsheet file and save it in a convenient 
location, using a new name (suggestion: store the spreadsheet in the same 
folder where you database is stored, and name it the same as your database, 
with an extension of .xls). 
 
The spreadsheet contains three worksheets – one for field definitions, one for 
pick-list definitions, and one for pick-list item definitions.  The pick-list definitions 
will be processed first, so references in the field definitions and pick-list item 
definitions may refer to either pre-existing pick-lists, or pick-lists to be added 
during the current execution of Batch Field Creatore. 
 
 
Field Definition Worksheet 
 
The worksheet holding the field definitions MUST be named “Fields” or “Sheet1”. 
 
The first row of the worksheet contains the “column headings” - names of what is 
to be found in each column - along with some “tooltip” help text, explaining what 
values are expected and/or required. 
 
Each row (after the first) contains the specifications for a field to be added to the 
database.  You can leave blank rows if you wish - perhaps to help visually group 
and organize your new fields.  Batch Field Creator will ignore the first row 
(expecting it to contain the column headers) and any blank row. 
 
Column A holds the Name of the field to be created.  (Remember that there are 
some fairly tight restrictions on what formulating ACT!2005 field names; please 
refer to the ACT!2005 documentation for more details.)  Each fieldname must be 
unique. This entry is mandatory. 
 
Column B holds the Type of the new field.  This entry is optional, and defaults to 
Character.  Valid entries are: 

Address or AD indicates an address field group 
Annual Event or AN or AE indicates an Annual Event field 
Character or CH indicates a Character field 
Currency or CU or $ or $$ indicates a Currency field 
Date or DA indicates a Date field 
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Date/Time or DT indicates a Date/Time field 
Decimal or DE indicates a Decimal field 
Email Address or EM indicates an Email Address 
Initial Capitals or IC or IN indicates an Initial Caps field 
Lowercase or LC or LO indicates a Lowercase field 
Memo or ME indicates a Memo field 
Number or NU indicates a Number field 
Phone or PH indicates a Phone field group 
Picture or PI indicates a Picture field 
Time or TI indicates a Time field 
Uppercase or UC or UP indicates an Uppercase field 
URL Address or UR indicates a URL field 
Yes/No or YE or YN indicates a Yes/No field 

(Please refer to the ACT!2005 documentation for more information on field types 
and their default settings.) 
 
Column C holds the Length of the field.  This entry is optional, and defaults to 
various values, depending on the field type (as established in column B).  For all 
text type fields (Character, Initial Caps, Lowercase, Uppercase), the default is 50.  
For Currency fields, the default is 16.2.  For Decimal fields, the default is 13.5.  
For URL fields, the default is 128.  When specifying a non-default value for a 
Character type field, Number field or URL field, specify the total length expressed 
as an integer (no decimal point or decimal digits - ex. 50, NOT 50.0).  When 
specifying a non-default length for a Currency or Decimal field, use a format that 
provides the left-of-decimal, dot, right-of-decimal lengths, with the maximum 
length of 18 (ex 13.2 for total length of 15).  Entries for Address, Annual Event, 
Date, Date/Time, Email Address, Memo, Phone, Picture, Time and Yes/No fields 
are ignored. 
 
Column D indicates whether or not the field is updatable.  This entry is optional, 
and defaults to True.  Valid entries are: Yes, No, True, and False. 
 
Column E indicates whether or not the field can be blank.  This entry is optional, 
and defaults to True.  Valid entries are: Yes, No, True, and False. 
 
Column F indicates whether or not changes to the field value generate history 
entries.  This entry is optional, and defaults to False.  Valid entries are: Yes, No, 
True, and False.  
 
Column G indicates whether or not the field is considered a “primary” field.  
This entry is optional, and defaults to False.  Valid entries are: Yes, No, True, 
and False. 
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Column H indicates the default value for the field.  This entry is optional, and 
defaults to blank for all field types except Yes/No.  For Yes/No fields, the default 
is No. 
 
Column I indicates the type of Field Change Trigger for the field, column K 
indicates the type of Field Entry Trigger for the field, and column M indicates the 
type of Field Exit Trigger for the field.  These entries are optional, and default to 
None.  Valid entries are Activity Series or A or AC or AS or Executable  or 
E or EX or None or blank. 
 
Column J indicates the actual Field Change Trigger, column L indicates the 
actual Field Entry Trigger, and column N indicates the actual Field Exit Trigger 
for the field.  These entries are optional, and default to blank.  Valid entries are 
blank or the text that accurately indicates the full trigger definition. 
 
Column O indicates the name of the pre-existing Picklist to be assigned to the 
field.  This entry is optional, and defaults to blank.  Valid entries are blank or the 
EXACT name of the existing Picklist in the ACT! database (including spaces, 
special characters, upper/lower case, etc). 
 
Column P indicates whether or not the field values will be “limited to picklist 
values”.  This entry is optional, and defaults to False.  Valid entries are: Yes, No, 
True, and False. 
 
Column Q indicates whether or not the field is allowed to “multi-select” from the 
picklist.  This entry is optional, and defaults to False.  Valid entries are: Yes, No, 
True, and False. 
 
Column R indicates whether or not the field is treated as “type ahead” for the 
picklist entries.  This entry is optional, and defaults to False.  Valid entries are: 
Yes, No, True, and False. 
 
Column S indicates whether or not the picklist will “show description”.  This 
entry is optional, and defaults to False.  Valid entries are: Yes, No, True, and 
False.  
 
Column T indicates the field “format” or “template” to be applied to values that 
are entered into this field.  For example, if you want a SSN to be separated by 
hyphens, you might use “xxx-xx-xxxx”.  This entry is option, and defaults to blank 
or nothing.  Consult your ACT! documentation for valid entries and formatting.  
 
Column U indicates the default Field Level Security for ACT!2007 (ACT! v9) or 
later.  This entry is option, and defaults to “ReadWrite”.  Valid entries are: Deny, 
ReadOnly and ReadWrite. 
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Once you have filled in a row for each new field, containing all the non-default 
values, save the spreadsheet.  
 
 
Pick-list Definition Worksheet 
 
The worksheet holding the pick-list definitions MUST be named “Picklists. 
 
The first row of the worksheet contains the “column headings” - names of what is 
to be found in each column - along with some “tooltip” help text, explaining what 
values are expected and/or required. 
 
Each row (after the first) contains the specifications for a pick-list to be added to 
the database.  You can leave blank rows if you wish - perhaps to help visually 
group and organize your new pick-lists.  Batch Field Creator will ignore the first 
row (expecting it to contain the column headers) and any blank row. 
 
Column A holds the Name of the pick-list to be created.  Each pick-list name 
must be unique. This entry is mandatory. 
 
Column B holds the Type of the new pick-list.  This entry is optional, and defaults 
to Character.  Valid entries are: 

Character or CH indicates a Character field 
Currency or CU or $ or $$ indicates a Currency field 
Decimal or DE indicates a Decimal field 
Number or NU indicates a Number field  

 
Column C holds the Description of the pick-list.  This entry is optional.   
 
Column D indicates whether or not the pick-list is editable by the users.  This 
entry is optional, and defaults to True.  Valid entries are: Yes, No, True, and 
False. 
 
Column E indicates whether or not the pick-list is auto-insert.  This entry is 
optional, and defaults to True.  Valid entries are: Yes, No, True, and False.  
 
(Please refer to the ACT!2005 documentation for more information on pick-lists 
and their settings.)  
 
Once you have filled in a row for each new pick-list, containing all the non-default 
values, save the spreadsheet.  
 
 
Pick-list Item Definition Worksheet 
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The worksheet holding the pick-list item definitions MUST be named 
“PicklistItems. 
 
The first row of the worksheet contains the “column headings” - names of what is 
to be found in each column - along with some “tooltip” help text, explaining what 
values are expected and/or required. 
 
Each row (after the first) contains the specifications for an item to be added to a 
pick-list in the database.  You can leave blank rows if you wish - perhaps to help 
visually group and organize your new pick-list items.  Batch Field Creator will 
ignore the first row (expecting it to contain the column headers) and any blank 
row. 
 
Column A holds the Name of the pick-list to which the item will be added.  This 
entry is mandatory. 
 
Column B holds the Value of the new item.  This entry is mandatory.   It is 
important that this column be formatted as “Text”, even though it may hold 
numerical values. 
 
Column C holds the Description of the pick-list.  This entry is optional.   
 
Once you have filled in a row for each new pick-list item, containing all the non-
default values, save the spreadsheet.  
 
 
 
 

Start Batch Field Creator 
 
Use your windows taskbar Start button menu of programs, and select the TNHG 
program group and the Batch Field Creator subgroup.  Select the Batch Field 
Creator option to start Batch Field Creator. 
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Use the File menu > Select ACT! Database option, or the Select File task panel > 
ACT! Database option, to open a standard Windows File Open dialog window.   
Navigate to and select the database where the fields will be defined. 
 
Use the File menu > Select Excel Spreadsheet option, or the Select File task 
panel > Excel Spreadsheet option, to open a standard Windows File Open dialog 
window.  Navigate to and select the spreadsheet holding the field specifications. 
 
Select the entity type for the new fields: Contact, Group or Company.  If you are 
only adding pick-lists and/or pick-list items, and not adding any fields, you may 
select any entity type – it will have no effect on the pick-list creation. 
 
If you have specified pick-list and/or pick-list item definitions to be added to the 
database, then “check” or select the “Include Picklists” option. 
 
Use the Create Fields menu, or the Create Fields button, to start the field 
creation process. 
 
During operation, if Batch Field Creator encounters any problems with the 
specifications found in the spreadsheet, it makes a log entry to record that 
situation.  In addition, a window will appear notifying you of the problem.  You 
can toggle the Options > Show Messages option on or off the control the display 
of these messages.  Each message will also offer you the option to “Continue 
and Show Messages (Yes)”, “Continue and Don’t Show Messages (No)”, or 
“Cancel”.  Since some messages are to be expected (see below) you may want 
to turn them off so that you don’t have to respond to each one.  You can always 
check the log (see below) for more information, even if you have optioned NOT 
to receive the messages. 
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One type of “problem” is when Batch Field Creator encounters a fieldname in 
Column A that already exists in the ACT! database.  This may or may not be a 
“real” problem; you may have restarted Batch Field Creator, and would want it to 
skip those fields that had already been added during an earlier execution, or, 
these “duplicate” names may be a surprise to you, and cause a real problem that 
needs resolution.  Using the message windows and the log, you should be able 
to isolate those situations that are real problems, and be able to resolve them 
quickly. 
 
Use the Log menu > View Logfile option and the Logfile task panel > View option 
to display the current activity log produced as Batch Field Creator performs its 
functions.  You can clear an old log using the Log menu > Clear Logfile option or 
the Logfile task panel > Clear option. 
 
(At the time of this publication, there is a known “undocumented feature” of ACT! 
by Sage, wherein some internal processing must periodically take place when 
adding fields to the database.  While the interactive Define Fields wizard handles 
this processing quite handily, Batch Field Creator cannot do so.  Therefore, you 
may encounter a situation where you will need to use the ACT! tools menu > 
Define Field option to manually add a field, and then resume processing with 
Batch Field Creator.  The window that appears provides the name of the field to 
be added in this fashion.  Just start ACT!, open the database, select the Tools 
menu > Define Fields option, select the proper Entity type (Contact, Group or 
Company), and Add New Field.  Add the field indicated in the error window, 
following the wizard to provide all non-default values, then click [Finish] and 
[Close].  Close the database and restart Batch Field Creator.  It will “remember” 
the selections for database, spreadsheet and type, so you should be able to just 
start the Create Fields operation, and resume where things left off before 
encountering this “feature”.  Sage Software indicates that they are planning on 
fixing the “feature” in some future release.) 
 
 
 


